npm安装依赖至指定版本的方法

简介

本文介绍npm安装依赖至指定版本的方法,依赖的版本可以在淘宝镜像官方查询到.

三种方法

方法一

先在package.json里修改好指定版本号,然后输入:

1
npm update webpack

方法二

1
npm update webpack@4.7.0

会把webpack更新至指定版本,但是不会写到package.json文件里,如果需要写到package.json里执行如下命令:

1
npm update webpack@4.7.0 --save

其中--save等于-S.

方法三

1
npm update webpack@latest -S

--save--save-dev区别

一句话:--save-dev是你开发时依赖的东西,--save是发布后还依赖的东西.

参考

  1. https://segmentfault.com/q/1010000009049039?_ea=1823977
  2. https://segmentfault.com/q/1010000005163089
显示 Gitment 评论